Home – New Forums Tell me straight… I value YOUR opinions!!!

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #972669
    TwiinPhotography
    Member
    • Total posts: 23
    Up
    0
    ::

    Good morning (omg it’s 12:13am)

    I’d LOVE any feedback you have surrounding my website, logo, branding, values, bio, portfolio and T&Cs aka ‘please read’ sections on my website http://www.twiinphotography.com.au

    I would TRULY APPRECIATE your feedback being entered into the below, anonymous, quick survey:
    http://www.surveymonkey.com/s/VCKDNXH

    I’m MORE THAN HAPPY to receive detailed suggestions/feedback within this thread also.

    I want YOUR opinion!
    Thanks in advance
    Mel

    #1057411
    Bizzy
    Member
    • Total posts: 64
    Up
    0
    ::

    Hi there,

    My thoughts are the page is well done, the gallery looks very nice. But a couple of things are letting it down. Areas to work on are:
    – Page took too long to load
    – Twin Photography logo looks blurry
    – My browser at the bottom keeps saying error loading page
    – It’s not immediately clear the Giant G is for contacting you
    – The link on the Giant letter is broken

    Hope this helps you fine tune the website!

    #1057412
    JacquiPryor
    Member
    • Total posts: 2,344
    Up
    0
    ::

    Hi Mel,

    I am going to go through and complete the online survey fully, brief look agrees with Bizzy’s post – that the site does take a long time to load. Am certainly not a web developer so not sure how/what can be done to quicken the loading time up?

    Also, from a brand/logo perspective, which fall into the area of ‘trademarks’ – I am going to send a P.M to you having had a quick look in the trademarks database to go over some information/findings.

    All the best,

    #1057413
    RaspberryBlack
    Member
    • Total posts: 47
    Up
    0
    ::

    Hi Mel,

    I just went through your survey.
    One thing that would concern me about your site is that it’s almost completely broken for people that don’t have JavaScript available (many users of moblie devices!). I attached a screenshot of what it looks like without Javascript (at least there is some content that could be found by search engines).
    But as it really shouldn’t be any problem with your design to make sure it looks good and works without JavaScript I wouldn’t forgo that.

    Cheers,
    Tina

    #1057414
    BrettM33
    Participant
    • Total posts: 1,372
    Up
    0
    ::

    One other thing to note is the site doesn’t show up at all if the user has AdBlock enabled in FireFox.

    #1057415
    TwiinPhotography
    Member
    • Total posts: 23
    Up
    0
    ::

    THANK YOU ALLvery very much! I am def going to make BIG chnages to my site over the next few weeks. THANK YOU!

    #1057416
    Netorigin
    Member
    • Total posts: 421
    Up
    0
    ::
    CondorCreative, post: 70837 wrote:
    One other thing to note is the site doesn’t show up at all if the user has AdBlock enabled in FireFox.

    I have AdBlock Plus enabled. The website is displaying fine in Firefox.

    Cheers,
    Shaun

    #1057417
    BrettM33
    Participant
    • Total posts: 1,372
    Up
    0
    ::
    NetOrigin, post: 71017 wrote:
    I have AdBlock Plus enabled. The website is displaying fine in Firefox.

    Cheers,
    Shaun

    Yep….. I just learned it was only an issue with a certain version of FireFox with a certain version of AdBlock (AdBlock was blocking all Flash it seems).

    Latest version of AdBlock fixes it & isn’t an issue at all with the latest version of FireFox.

    #1057418
    TwiinPhotography
    Member
    • Total posts: 23
    Up
    0
    ::

    Okay, I’ve leaned in on all the very helpful comments and suggestions and the end result is: http://www.twiinphotography.com.au

    Thoughts? :) THANKS SO MUCH!!!!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.