Home – New Forums Tech talk Javascript issues

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #967578
    fad-cate
    Member
    • Total posts: 13
    Up
    0
    ::

    Can anyone help with a javascript problem? My website has a small javascript running on the front page that generates a random image. It works on Safari, Firefox, Opera and even Internet Explorer on the mac. But it seems to be a bit shaky on IE on a pc. It appears that the image doesn’t show but the linking caption does. I thought it might be due to javascript disabled on individual people’s computer but they seem to be able to view my javascript galleries on the other pages ok. Can someone have a look and see what I’ve done wrong? Thanks!

    #1027302
    vxd
    Member
    • Total posts: 78
    Up
    0
    ::

    Hi,

    I thought they stop making IE for Mac.

    The problem seems to be this line of code here

    After the Fire[/CODE]

    width=”auto” height=”auto”
    It could just be IE but if you actually specify the width and height the image will show.

    There could be a work around so you can use auto. Just google Width auto and IE[CODE]After the Fire[/CODE]

    width=”auto” height=”auto”
    It could just be IE but if you actually specify the width and height the image will show.

    There could be a work around so you can use auto. Just google Width auto and IE

    #1027303
    SydneyWebService
    Member
    • Total posts: 51
    Up
    0
    ::

    OR try to get rid of the width and height auto all together. That seems to be working okay in IE

    #1027304
    vxd
    Member
    • Total posts: 78
    Up
    0
    ::

    Yeah, Getting rid of width and height works too

    #1027305
    fad-cate
    Member
    • Total posts: 13
    Up
    0
    ::

    How simple that sounds!
    Ok, I’ll try that, thanks. I’m not much of a programmer but i thought it seems strange that it was working in everything but IE.

    #1027306
    SydneyWebService
    Member
    • Total posts: 51
    Up
    0
    ::
    fad-cate, post: 32298 wrote:
    How simple that sounds!
    Ok, I’ll try that, thanks. I’m not much of a programmer but i thought it seems strange that it was working in everything but IE.

    Hey..if you need my help, I would be glad to change it for you

    #1027307
    fad-cate
    Member
    • Total posts: 13
    Up
    0
    ::

    Great, Thanks! Works now but can anyone tell me why it does that flicker effect?

    #1027308
    SydneyWebService
    Member
    • Total posts: 51
    Up
    0
    ::

    Can post the actual source code?

    #1027309
    fad-cate
    Member
    • Total posts: 13
    Up
    0
    ::

    fad studios – fine art and design

    fad studios art of the day
    After the Fire

    After the Fire

    [/CODE]

    It’s like the code picks an image and then changes its mind and pics something else.[CODE]fad studios – fine art and design

    fad studios art of the day

    After the Fire

    After the Fire

    [/CODE]

    It’s like the code picks an image and then changes its mind and pics something else.

    #1027310
    vxd
    Member
    • Total posts: 78
    Up
    0
    ::

    I noticed the flicker before and I thought it had something to do with
    After the Fire
    [/CODE]

    What I think is happening is when the website is loaded it will Load the after fire image and then load the random image.

    Try

    [CODE]
    [/CODE][CODE]After the Fire
    [/CODE]

    What I think is happening is when the website is loaded it will Load the after fire image and then load the random image.

    Try


    [/CODE][CODE]
    [/CODE]

    #1027311
    fad-cate
    Member
    • Total posts: 13
    Up
    0
    ::

    Thanks, I’ll give it a go.

    #1027312
    anna007
    Member
    • Total posts: 1
    Up
    0
    ::

    Great, Thanks! Works now but can anyone tell me why it does that flicker effect?
    ………….
    free web hosting

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.